Back to overview
AWS Connectivity Issues with US-East-1
Mar 20, 2026 at 04:24pm UTC
Affected services
Ingestion By Protocol
AWS Regions
Resolved
Mar 20, 2026 at 04:24pm UTC
We are currently experiencing connections issues with AWS specifically US-EAST. There could be delays in ingestion from Cloudwatch services. We are currently investigating the incident.
UPDATE: this is resolved and missing metrics will backfill
Affected services